Upload Documents in airtable

Hello,

i use airtable integration as database. How can i upload files as attachments in airtable via jet admin? I can display and download files from airtaible, but cant upload files.

best regards

1 Like

@JetTeam Could someone please support and answer the question?

Regardless of the resource, the file download is identical. I understand correctly that in Airtable you have a field with type Attachments, Jet Admin should automatically define such a field as File type.

Then you can automatically download and view your files if you have generated Admin Panel, if you are building an application from scratch, then you just need to pass the File field value in the input of your Create/Update action.

Please clarify exactly what you are stuck in, as I see from your message that you have already worked with this field. A quick loom video would be appreciated.

Yes, you understand correctly that in Airtable the field type is Attachments. And yes, Jet Admin automatically define the field as File type.

However the problem is not the download of the files, but rather that no upload is possible. As soon as I want to upload a file, I get the error message “Given token not valid for any token type” from Jed Admin.

Strange is that after I tried to reproduce the error message for answer here, the file-upload suddenly worked without me changing anything in JetAdmin. At a second attempt (without changing any setting from the file picker element), it did not work again and the error message appears at every attempt since then.

Here you can see the form and the error message:

and the settings from the file picker element in Jet Admin:

Hi, am having the exact same issue, exactly as described - with one exception. I have not been able to get it work, ever.

I have also attempted using the Formula field as attached

Has anyone been able to get the file upload to work? I am now looking for guidance in this area. The error I’m receiving when trying to upload the file to the form is “Environment not found”. I’m using the “Rest API - Temporary” option. Not sure what all I’m missing.