Select all rows of a Jetadmin table in a workflow

First message of a new Jetadmin user :slight_smile:

I’m trying to delete all rows of a Jetadmin table using a workflow, triggered by a button.
Unfortunalty, when using a the Get record list action on my collection, I only get 19 records (my table has more than 100 records).
I’ve also tried an SQL query, but same result.

Could you tell me if I missed something ?

Thanks in advance :slight_smile:

This is an example of looping on a set of records and deleting some of them depending on a condition. If you dont have a condition and you want to delete all the list . then it is much easier, all you have to do is to loop on all the records and within the loop you delete each record one by one.

Hi Mohammed,

Thanks for your reply !
My problem is this hard limit of 20 records I get when I try to get all records of a Jet Table.

I’m struggling to understand where I can change this value.
I don’t have this limit if, for example, I manually select all rows and create an automation based on the selected rows…

I really don’t understand :upside_down_face:

Do you mean the iterator doesnt bring all the data and only brings 20 records ?

The Get record list action return only 20 records.

The problem is in the Get record list, and not in the iterator :+1:


Maybe someone has an explanation ? I’m still stuck with this issue :upside_down_face:


Currently the get record list and the page queries are limited with 20 records per request.
I already reported this issue to the dev team, but i will ask you for applying for a feature to bring all records.

you can apply for it here: Feature requests | Jet Admin - we’re regularly reviewing the requests and put the most popular/important ones on our roadmap. :slightly_smiling_face:

Hi Mohammed,

Thanks for you answer !
I’ve created a feature request here : Retreive all records for Get record list action | Voters | Jet Admin