New firebase fields not appearing as data manager columns

I added a new record in Firebase that has a number of new fields but they don’t show in Jet Admin data manager. I’ve tried “sync now” and I’ve tried “Recreate schema”. Is there something else I need to do so JetAdmin can "discover’ these new fields? Or to select the fields so I can use them?

I tried connecting to this firebase collection from JetAdmin from scratch and still can’t see the new fields. Note that these fields are rare. They only appear in one out of ~3000 rows. In other rows they don’t exist.
Could it be:

  • JetAdmin doesn’t scan every row?
  • JetAdmin ignores some rows that are very rare?
  • I haven’t set correct access to these rows in Firebase in some way?

progress update. I think the first bullet above is my problem.
I went to Firebase and added all the fields I need to my first record. Then when I did “recreate schema” the columns appeared in the data editor.

Yes, it means that you updated the structure on firebase side. but after updating the scheme it synced and works fine.

Jet Admin only indexes the first 30-50 records of a collection or so. So you should always add your schema updates in one of these first records (in the first sub-collection). It’s an annoying workaround, but it will work.