Firestore Synchronized Failed & Integration Failed

Hi, I have been using Jet Admin with Firestore integration (“Direct connection” mode, not “Sync” mode) for about a month.
There are some changes (many new fields in documents etc.) in our Firestore database, and I tried to use “Sync Structure”. But it failed and said “Synchronized Failed. Resource structure update failed”
(Screenshot 1 in the drive)

Then I created a brand new App, and tried to add Firestore as a data source. I did what I did before - upload the Firestore private key json, but it said “Integration with data source failed: Query failed, please check your network connection and try again”
(Screenshot 2 in the drive)

My network connection is ok. Are there any other factors that can cause these? I don’t really think changes we made on Firestore caused these.
It would be so great if anyone would help.

Hello @Gim_Proto
Have you had any changes on the Firebase side in terms of permissions and data access?

Hi @JetTeam ,
Thanks for your reply! I don’t think so but I will check with my teammates. However I found it a bit weird. I have been using the Firestore integration for CRM usage and create new documents / update documents. Like what you did in this document.
And they are still working. I can still create/update my Firestore documents.
But “Sync Structure” and “Add Firestore as Data Source” are not working.

Hi @JetTeam,
we opened developer console in chrome when clicking "Sync Structure” button,
and these were the errors we saw:

We were wondering if this could be the problem.

Could you please invite my email as an administrator so I’ll be able to check it?

Hi @JetTeam , the issue was somehow gone “once” but it came back again.
We were in free plan and we needed to change to Starter plan to invite you.
The first time I clicked “Switch to starter” button I got the red error notification in top-right corner just like what I got when clicking “Sync Structure”.
I decided to click it again, but before I did that, I changed it from monthly to annual (the red arrow in the screenshot) and I saw a green notification in top-right corner. Then I click “Switch to starter” button again and there was no red error notification this time and the payment window successfully popped up.
So, I thought maybe “Sync Structure” will work this time… and I went to the Firestore data source page to click “Sync Structure”. And it works! But it worked just once and didn’t work after that.

Before we can switch to starter and invite you, we have another issue here: we choose $30 “Switch to Starter” but the payment popup shows $60, if we try “Switch to Pro” it shows $120. Did we miss anything? :sweat_smile:

Thank you

@Gim_Proto You have 2 users in the project and therefore you will be charged $30 * 2 users = $60

Hi @JetTeam , oh got it, thanks. We’ve sent you the invite.

Hi @JetTeam , we were wondering if you have updates on this?
Thank you!

@Gim_Proto We are working to fix this issue. I’ll let you know.

Hi @JetTeam, Thank you very much!

Hi @JetTeam , I was wondering if by any chance you’d have a timeframe when this issue will be fixed.
Thanks again!