Documint Template merge

I would like to pass data from JetAdmin to a Documint template using the RestApi integration, in the same way you can see in this videotutorial by @anton :

What isn’t working for me:
the resulting PDF document has the correct template assigned, but the variables I pass aren’t loaded (it’s empty).

What I already checked:

  • POST method for the http query
  • api-key double checked and sent as header
  • document_id passed as input (this is working, it generates PDF from the selected template)
  • body with all the needed variables inside a brace (with and without quotation marks)
  • variable names and variables order double checked so that it reflects the template
  • I tried passing the variables data from a different table, then tried compiling them at runtime as “asked to user”, then tried to write the values directly in the http query’s body. No joy.
  • the Request panel, in the Http Query editor in JetAdmin, shows that the variables are passed correctly, they just aren’t loaded in the generated PDF that I can see in the iframe file viewer or browsing the Result’s url

After redoing the job from scratch many times, I think I am missing something obvious, but I really can’t tell where I am making a mistake.
If it can help to solve the problem, I will happily share the app page.

Thank you very much to anyone who can suggest how to solve.

Hi Roberto,

I get the same issue. Variables are not replaced in the pdf file.

I checked the request in Chrome console :

@jet_admin : Is there something wrong ?

It works fine in Postman when I use the same body : variables are replaced in the generated pdf file

How I configured the action in JetAdmin :

… in Postman

Hi mezkaljet,
it seems we configured the query almost in the same way. I’m curious to know what the reason can be.
I can add that both my and accounts are the free ones for now. I couldn’t read about limitations on this specific field, but why not. In the end, I am just curious to know if I am making a mistake, or if it is a bug, just so I know how to proceed in my choice of tools for the app I’m making.

I’m also on free accounts but I think that’s not the issue here because I’m getting a 200 code response from the Documint API via JetAdmin and Postman.

Let’s see what @jet_admin think about that

Please @jet_admin : can you help us on this one ?

So, no one is generating pdf !?

Please, if someone is able to generate PDF, provide us a little HOW-TO… :pray:

Hi @jet_admin , @JetTeam ! Sorry to bother you but I really need this feature to work…

Is there any tip you can give me to understand how PDF generation works with Documint ?